Latest Posts

Topic: multiplayer tournament 2020

WorldSavior
Avatar
Joined: 2016-10-15, 04:10
Posts: 1687
Ranking
One Elder of Players
Location: North of Germany
Posted at: 2020-06-13, 13:58

Nordfriese wrote:

That bug is a known issue with the suggested teams box that surfaces only in debug builds, not in release builds.

Good to know

Likely that amz6762 already has it as well.

You mean the debug version of that version, not the release, right?

Generally I would recommend to play tournaments with release builds only because players can use debug builds to get some unfair advantages face-wink.png

+1


Top Quote
king_of_nowhere
Avatar
Joined: 2014-09-15, 18:35
Posts: 1636
Ranking
One Elder of Players
Posted at: 2020-06-13, 22:02

so? which build should be used? amazon 6762 or something more recent?

Nordfriese wrote:

Generally I would recommend to play tournaments with release builds only because players can use debug builds to get some unfair advantages face-wink.png

abusing bugs is against the rules.

sometimes it's hard to say what is actually a bug, though


Top Quote
Nordfriese
Avatar
Joined: 2017-01-17, 18:07
Posts: 900
Ranking
One Elder of Players
Location: 0x55555d3a34c0
Posted at: 2020-06-13, 22:48

Although as a non-participant I don't have a say I'd really recommend that you'd use the latest amazon build. It just doesn't make sense to use an ancient version containing lots of already-fixed bugs and missing a fairly large number of cool new features IMHO.

amazons-7461: appveyor installers 64 bit 32 bit
75189d8c2182065599fa0f72ee56737f4f644ed6

sometimes it's hard to say what is actually a bug, though

The additional options featured by debug builds are not bugs, they're features. E.g. the possibility to inspect other players' infrastructure or to give oneself extended vision. This is technically not forbidden by the rules in the first post…


Top Quote
WorldSavior
Avatar
Joined: 2016-10-15, 04:10
Posts: 1687
Ranking
One Elder of Players
Location: North of Germany
Posted at: 2020-06-14, 01:45

Nordfriese wrote:

Although as a non-participant I don't have a say I'd really recommend that you'd use the latest amazon build. It just doesn't make sense to use an ancient version containing lots of already-fixed bugs and missing a fairly large number of cool new features IMHO.

amazons-7461: appveyor installers 64 bit 32 bit
75189d8c2182065599fa0f72ee56737f4f644ed6

-1

training bug, only English works, no other languages.

I'd say it would be better to pick the amazon build right before the training change

Searching that thing on appveyor and github was not trivial at all : D

Windows build x64: https://ci.appveyor.com/project/widelands-dev/widelands/builds/32111302/job/ouod11v5sd2jg4c2/artifacts

Windows build x86: https://ci.appveyor.com/project/widelands-dev/widelands/builds/32111302/job/x3w94mhoc7xjh5g4/artifacts

Appveyor and github are driving me crazy. Which is the correct github commit which delivers the Linux version which is compatible to that windows version?

sometimes it's hard to say what is actually a bug, though

The additional options featured by debug builds are not bugs, they're features. E.g. the possibility to inspect other players' infrastructure or to give oneself extended vision. This is technically not forbidden by the rules in the first post…

But it should be. Maybe it would be better to not tell everyone right here that those cheating possibilities exist.

Good that we have now a bug which can expose debug build users : D

king_of_nowhere wrote:

so? which build should be used? amazon 6762 or something more recent?

I'd say the version before the training change (see above)

amazon 6762 contains an annoying healing bug... The marble mine bug is also annoying for empire players, if there are some here.

Nordfriese wrote:

Generally I would recommend to play tournaments with release builds only because players can use debug builds to get some unfair advantages face-wink.png

abusing bugs is against the rules.

sometimes it's hard to say what is actually a bug, though

That's true

Edited: 2020-06-14, 01:47

Top Quote
WorldSavior
Avatar
Joined: 2016-10-15, 04:10
Posts: 1687
Ranking
One Elder of Players
Location: North of Germany
Posted at: 2020-06-14, 01:48

By the way, when does the tournament start already? Is one of the first matches really kings_of_mars vs World-X on Wisent valley?


Top Quote
Nordfriese
Avatar
Joined: 2017-01-17, 18:07
Posts: 900
Ranking
One Elder of Players
Location: 0x55555d3a34c0
Posted at: 2020-06-14, 11:08

Appveyor and github are driving me crazy. Which is the correct github commit which delivers the Linux version which is compatible to that windows version?

The best way to find out is to search through the commit history on GitHub and follow the appveyor link from this commit…


This is hijacking this thread a bit, and I'm not even participating, so one might well ask why I even care, so I'll keep this short. So far there is one person who is complaining about one new feature in latest master. A pretty good feature by the opinion of other people. So I do not think it appropriate that you try to force all other tournament players to use an older version because of that. Are you not planning to play build21 at all? The new algorithm is working well in the opinion of just about everyone who voiced their opinion on it except you so it is not going to be fundamentally reworked anytime soon.


Top Quote
WorldSavior
Avatar
Joined: 2016-10-15, 04:10
Posts: 1687
Ranking
One Elder of Players
Location: North of Germany
Posted at: 2020-06-14, 12:46

Nordfriese wrote:

Appveyor and github are driving me crazy. Which is the correct github commit which delivers the Linux version which is compatible to that windows version?

The best way to find out is to search through the commit history on GitHub and follow the appveyor link from this commit…

Is it not easier to go from the appveyor link to the Git page? I just need to know which of the two links is the right one.


This is hijacking this thread a bit, and I'm not even participating, so one might well ask why I even care, so I'll keep this short. So far there is one person who is complaining about one new feature in latest master. A pretty good feature by the opinion of other people. So I do not think it appropriate that you try to force all other tournament players to use an older version because of that.

I don't try to force anyone. I even pointed out the possibility of using several versions in the tournament.

Are you not planning to play build21 at all?

Why such a question? I also play peaceful mode, where soldier training doesn't matter.

The new algorithm is working well in the opinion of just about everyone who voiced their opinion on it except you so it is not going to be fundamentally reworked anytime soon.

At the other hand I know much more about Widelands gameplay than everyone else, so I see things in new features which nobody else sees, no matter how big the group is.


Top Quote
hessenfarmer
Avatar
Joined: 2014-12-11, 23:16
Posts: 1389
Ranking
One Elder of Players
Location: Bavaria
Posted at: 2020-06-14, 13:28

WorldSavior wrote:

amazons-7461: appveyor installers 64 bit 32 bit
75189d8c2182065599fa0f72ee56737f4f644ed6

-1

training bug, only English works, no other languages.

Apart of whether the new training selection algorithm would be considered a bug or a feature, the language issue sound weird. How dio you mena this as This should have the same translations in as master from 12.06.20. However Everything related to Amazons has no translation at all and never had due to this being still a development branch and so no Amazon texts are currently on transifex.


Top Quote
WorldSavior
Avatar
Joined: 2016-10-15, 04:10
Posts: 1687
Ranking
One Elder of Players
Location: North of Germany
Posted at: 2020-06-14, 21:04

hessenfarmer wrote:

WorldSavior wrote:

amazons-7461: appveyor installers x64 x86
75189d8c2182065599fa0f72ee56737f4f644ed6

-1

training bug, only English works, no other languages.

Apart of whether the new training selection algorithm would be considered a bug or a feature, the language issue sound weird. How dio you mena this as This should have the same translations in as master from 12.06.20.

One can only chose "English" or "Try System Language" and even though my system language is German, the game is only in English then.

However Everything related to Amazons has no translation at all and never had due to this being still a development branch and so no Amazon texts are currently on transifex.

I know. But this doesn't stop working translations of other content in the version 6762.

Edited: 2020-06-17, 08:59

Top Quote
hessenfarmer
Avatar
Joined: 2014-12-11, 23:16
Posts: 1389
Ranking
One Elder of Players
Location: Bavaria
Posted at: 2020-06-14, 21:32

WorldSavior wrote:

hessenfarmer wrote:

Apart of whether the new training selection algorithm would be considered a bug or a feature, the language issue sound weird. How dio you mena this as This should have the same translations in as master from 12.06.20.

One can only chose "English" or "Try System Language" and even though my system language is German, the game is only in English then.

I just downloaded and installed the latest Amazon build from appveyor. A full language directory was present and working, so either you run it with datadir option on a data directory without a locale directory or something went wrong in your installation.

However Everything related to Amazons has no translation at all and never had due to this being still a development branch and so no Amazon texts are currently on transifex.

I know. But this doesn't stop working translations of other content in the version 6762.

This is not related to the build but to your installation. You could PM me to solve this out if you need support.


Top Quote