Important Dates

Currently Online

Latest Posts

Topic: Bugs between build20 and build21

WorldSavior
Avatar
Joined: 2016-10-15, 04:10
Posts: 1496
Ranking
One Elder of Players
Location: North of Germany
Posted at: 2020-02-24, 18:39

GunChleoc wrote:

Please don't report the ware routing bug again, since it has already been reported multiple times face-wink.png

As you wish

We never officially supported starting a game with more than 8 players. That feature was only introduced for AI training. I will consider it after I have finished making the singleplayer start game screen looking like the multiplayer screen and when that code has been unified. Less work for me that way face-wink.png

Makes sense

Won't happen for Build 21 though as I'm trying to finish up my features and go into bug fixing mode.

Okay...

GunChleoc wrote:

Niektory provided a fix for the ware routing saveloading bug. It won't fix broken savegames, but it should not reoccur with new savegames. Please report again if you see the bug again in new games.

https://github.com/widelands/widelands/pull/3712

Great! Thanks, Niektory


“It's a threat to our planet to believe that someone else will save it.” - Robert Swan

Top Quote
WorldSavior
Avatar
Joined: 2016-10-15, 04:10
Posts: 1496
Ranking
One Elder of Players
Location: North of Germany
Posted at: 2020-03-05, 21:09

Bug in multiplayer:

if you load a match, it shows "no team" everywhere even when there are teams. (by the way it's confusing with the colors. i recommend to replace team colors by team numbers again)

and it also reveals the tribes of random tribe. which should be still shown as random.


“It's a threat to our planet to believe that someone else will save it.” - Robert Swan

Top Quote
GunChleoc
Avatar
Joined: 2013-10-07, 15:56
Posts: 3159
Ranking
One Elder of Players
Location: RenderedRect
Posted at: 2020-03-06, 12:33

Thanks! https://github.com/widelands/widelands/issues/3739


Busy indexing nil values

Top Quote
JanO
Avatar
Joined: 2015-08-02, 11:56
Posts: 120
Ranking
At home in WL-forums
Posted at: 2020-03-20, 09:47

Not really a bug, but an inconsitency: In the current PPA-Version bzr9220-202003170718 (Release)

https://code.launchpad.net/~widelands-dev/+recipe/widelands-daily

I wonder if it would be better, if ships would act the same when loading and unloading wares. At the moment wares are unloaded one by one (1-2 per second, did not measure it) while loading wares happens immediately. Looks a bit weird.


Top Quote
Nordfriese
Avatar
Joined: 2017-01-17, 18:07
Posts: 706
Ranking
One Elder of Players
Location: 0x55555d3a34c0
Posted at: 2020-03-20, 10:37

+1 for changing this. For implementation reasons loading wares one by one would be very hard to do, while unloading them one by one is easy. So let's change to both loading and unloading wares immediately?

P.S. ships currently unload one ware every 1500 ms

Edited: 2020-03-20, 10:38

Top Quote
WorldSavior
Avatar
Joined: 2016-10-15, 04:10
Posts: 1496
Ranking
One Elder of Players
Location: North of Germany
Posted at: 2020-03-20, 10:39

Nordfriese wrote:

So let's change to both loading and unloading wares immediately?

Yes please

+1


“It's a threat to our planet to believe that someone else will save it.” - Robert Swan

Top Quote
WorldSavior
Avatar
Joined: 2016-10-15, 04:10
Posts: 1496
Ranking
One Elder of Players
Location: North of Germany
Posted at: 2020-03-27, 18:25

Regression bug: Economy settings of Atlantean Blackroot Flour are missing, spotted in Amazons6762


“It's a threat to our planet to believe that someone else will save it.” - Robert Swan

Top Quote
hessenfarmer
Avatar
Joined: 2014-12-11, 23:16
Posts: 1177
Ranking
One Elder of Players
Location: Bavaria
Posted at: 2020-03-27, 18:54

WorldSavior wrote:

Regression bug: Economy settings of Atlantean Blackroot Flour are missing, spotted in Amazons6762

they were removed due to being consistent with e.g. empire wine. see https://github.com/widelands/widelands/pull/3682


Top Quote