Latest Posts

Topic: It's a long way to Tipperary!

mxb2001
Avatar
Topic Opener
Joined: 2019-05-20, 17:49
Posts: 267
OS: Linux
Version: 1.2
Ranking
Tribe Member
Location: The land of the thirsty spider
Posted at: 2023-04-28, 18:48

Hej, so I installed this addon but it gives an error about winter taiga 1 when I try to run it. Does that mean it needs 1.1? If so, does that mean the addons don't make sure you can only dowload ones you can use?

(I hope to soon move from Debian 9 to 10 or 11 but it looks scary, the whole backup all your stuff first is where I'm hung up on for now - gah I miss the good old DOS days when you just SYS the HD with all of the 3 system files... it was beautiful)


--
To Boldly Go Where No Man Has Gone Before

Top Quote
Nordfriese
Avatar
Joined: 2017-01-17, 17:07
Posts: 1983
OS: Debian Testing
Version: Latest master
Ranking
One Elder of Players
Location: 0x55555d3a34c0
Posted at: 2023-04-28, 19:38

Funny, I'm playing on that map right now face-grin.png

Yes, it's a post-1.0 map, so you need Widelands 1.1 or newer to play it. Add-ons do have a field to set a minimum and/or maximum Widelands version, but it's up to the add-on's author to actually fill it in, so not everyone does that. Maps alone can not currently check version requirements. Ideally they just show you an Unhandled Packet Version Error when you try to load an incompatible map.


Top Quote
kaputtnik
Avatar
Joined: 2013-02-18, 19:48
Posts: 2476
OS: Archlinux
Version: current master
Ranking
One Elder of Players
Location: Germany
Posted at: 2023-04-29, 17:38

Nordfriese wrote:

Add-ons do have a field to set a minimum and/or maximum Widelands version, but it's up to the add-on's author to actually fill it in, so not everyone does that.

With the new option in the editor "Publish this map online" an author has no chance to set the minimum wl version. The map i uploaded recently with this option has this information, but as a comment in the addon-file:

# Automatically created by Widelands 1.2~git26087 (e5bc531@master) Debug

Because of the bumped terrain indices all maps created with version 1.2 (current development version) aren't playable with a widelands version <1.2. A maps author will likely never know such changes (and shouldn't need to have, imho), but the developers do know. So the "min_wl_version" should be set automatically, at least for maps, if possible face-smile.png


Fight simulator for Widelands:
https://wide-fighter.netlify.app/

Top Quote
Nordfriese
Avatar
Joined: 2017-01-17, 17:07
Posts: 1983
OS: Debian Testing
Version: Latest master
Ranking
One Elder of Players
Location: 0x55555d3a34c0
Posted at: 2023-04-29, 18:52

Which reminds me that we could in principle reuse the code we have for the website's compatibility check. Will create a branch to both set the map set add-on minimum version automatically from it and to add some checks to the mapselect UI.


Top Quote