Currently Online

Latest Posts

Topic: Unable to run, build or update

Tribal-Chief
Avatar
Joined: 2018-12-09, 17:16
Posts: 31
Ranking
Pry about Widelands
Posted at: 2019-07-14, 13:02

For the last month I have been unable to start any game, new game or tutorials all crash just before displaying the world. According to the terminal output alll data blocks load, then

GameLoader::load() took 51ms

Done reloading the game from replay

Replay writer has started

[sync] Reset

Segmentation fault (core dumped)

The strange message about reloading from replay might be a clue as I do not have replays and certainly do not load them. The error started after trunk update to include building work area conflicts and has persisted through several updates.

Assuming it might be something I had done and I had something wrong in my configuration directory I deleted `/.widelands and let the gme create a new one, but the results was the same.

I decided to start from the begining and deleted the widelands-repo directory and the checked out a current version to compile with the supplied script, it failed to compile due to errors in interactive_gamebase.cc and interactive_player.cc. I checked the files I had with those online and saw no difference and the reran the compile script, this started to compile after the two error files, the script seems to assume that if something has been built previously and has no change the it does not need to be recompiled, this means the two files that were reported as errors on the first run were not compiled correctly and trying to run the game segfaults.

I then tried the Archlinux bzr build but that fails with

/bin/ld: ../../graphic/libgraphic_gl_utils.a(initialize.cc.o): undefined reference to symbol 'glDrawBuffer' /bin/ld: /usr/lib/gcc/x86_64-pc-linux-gnu/9.1.0/../../../../lib/libGL.so: error adding symbols: DSO missing from command line collect2: error: ld returned 1 exit status make[2]: [src/economy/test/CMakeFiles/test_economy.dir/build.make:499: src/economy/test/test_economy] Error 1 make[1]: [CMakeFiles/Makefile2:10123: src/economy/test/CMakeFiles/test_economy.dir/all] Error 2 make: *** [Makefile:141: all] Error 2 ==> ERROR: A failure occurred in build(). Aborting... ==> ERROR: Makepkg was unable to build widelands-bzr.

I have also tried building from git but I have not been able to get my fork mirrored for a month and building from git has always been problamatic.


Top Quote
kaputtnik
Avatar
Joined: 2013-02-18, 20:48
Posts: 1765
Ranking
One Elder of Players
Location: Germany
Posted at: 2019-07-14, 13:40

[sync] Reset

Segmentation fault (core dumped)

This happens only for release builds. Debug builds work fine: See Implent support for gcc9 Either downgrade gcc or compile only debug builds. Or even better: Try to find the reason and may provide a fix face-smile.png

The thing with the arch package is also known, but since it is related to the package, it must be solved by the maintainer. Have you tried to ask over there?


Top Quote
niektory
Avatar
Joined: 2019-06-03, 20:06
Posts: 31
Ranking
Pry about Widelands
Posted at: 2019-07-14, 22:44

See also this thread: build fails on arch linux 32bit


Top Quote