Latest Posts

Topic: error when starting second imperial campaing

Psychotiker

Topic Opener
Joined: 2010-04-09, 22:25
Posts: 2
Ranking
Just found this site
Posted at: 2010-04-09, 22:58

Hi all,

I really enjoy this game - at least as far as got until now.

When starting the fifth campaign I get the following error:

[/Users/alvin/Documents/widelands-build15-rc2-src/src/profile/profile.cc:722][] elemental:10: CR not immediately followed by LF

Playing on a mac mini/OSX 10.6.3

any help is appreciated


Top Quote
SirVer

Joined: 2009-02-19, 14:18
Posts: 1445
Ranking
One Elder of Players
Location: Germany - Munich
Posted at: 2010-04-10, 10:35

Hi,

intel or g4 mac mini? The problem you describe is strange, you can try to fix it yourself by editing the corresponding file inside the Widelands.app package: Resources/campaigns/emp01.wmf/elemental and check the 10. line. The best idea is to completly erase it and type it out again.

Good luck. !SirVer


Top Quote
Psychotiker

Topic Opener
Joined: 2010-04-09, 22:25
Posts: 2
Ranking
Just found this site
Posted at: 2010-04-10, 15:53

Hi SirVer,

Thanks for the hint. I had to replace the file. The correct path on macis "widelands.app/Contents/MacOS/game/campaigns/emp02.wmf/elemental"

Thanks and keep up the good work

Psy

ps: it's an intel-mac


Top Quote
QCS

Joined: 2009-12-29, 21:47
Posts: 256
Ranking
Tribe Member
Posted at: 2010-04-11, 12:17

Problem is understood and has been (hopefully) fixed by a teamwork effort between TinoM and myself on Launchpad translations.

In translations, it is not wise to use line breaks (\r\n characters). When a line break should appear in the text, at the specified points
has to be used.

Next update of Launchpad translations to the translations branch will reveal if we managed to hunt every occurence of \r\n characters.

It might be a good point to add this to a translation FAQ.

Edited: 2010-04-11, 12:17

CMake is evil.

Top Quote
SirVer

Joined: 2009-02-19, 14:18
Posts: 1445
Ranking
One Elder of Players
Location: Germany - Munich
Posted at: 2010-04-11, 12:48

QCS, you might want to open a bugreport for the launchpad translation project. Maybe they can solve this in a proper way. Or they could add scripting support for translations.. that would be great.


Top Quote
QCS

Joined: 2009-12-29, 21:47
Posts: 256
Ranking
Tribe Member
Posted at: 2010-04-11, 13:10

https://bugs.launchpad.net/launchpad/+bug/560652

Let's see if they can help us with that face-smile.png


CMake is evil.

Top Quote
samithdisal
Avatar
Joined: 2010-03-08, 14:46
Posts: 66
Ranking
Likes to be here
Location: Sri Lanka
Posted at: 2010-04-12, 09:03

face-smile.png


NoOb KiWwaTa NoOb Ma NeWeI

Top Quote