Currently Online

Latest Posts

Topic: crashed on game start with build "svn4341"

Elderbree_TM
Joined: 2009-06-30, 22:23
Posts: 2
Ranking
Just found this site
Posted at: 2009-07-01, 06:00

Hello dear creators/developers/whomever it may concern :).

I just downloaded the svn4341 build and sconsed it (as in ran scons from the widelands directory) (see below for the scons -n output)

When I start the game (be it a campaign or a regular single player and with or without auto save) I get the following massage (and I'm sent to the main screen).

^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^

Unexpected error during the game [src/world.cc:171] Error loading world greenland: [src/world.cc:234] worlds/greenland/conf: [src/profile.cc:721] Section [immovable types] not used (did you spell the name correctly?)

Please report this problem to help us improve Widelands. You will find related messages in the standard output (stdout.txt on Windows). You are using build Build13. Please add this information to your report.

Widelands attempts to create a savegame when errors occur during the game. It is often - though not always - possible to load it and continue playing. ^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^

also after removing the scons with a "scons -c" command I ran a "scons -n" command to get the steps scons took inorder for you to review and see if maybe it crashes because I'm missing something,

scons -n is in this open document link because of length. http://docs.google.com/View?id=dd32c8gw_9fc3957cp

As a side note.. I'm very new to Linux and am still learning the ropes.

I'm using "Fedora 11" if it is of relevance

Thanks in advance

    Elderbree TM

Top Quote
sigra
Joined: 2009-03-05, 19:02
Posts: 130
Ranking
At home in WL-forums
Location: Orsa
Posted at: 2009-07-01, 08:19

Looks like you executed "widelands" and your system started an old installed version instead of the version that you just built. Try "./widelands" instead (from the same directory where you executed "scons").

Edited: 2009-07-01, 08:37

Top Quote
Elderbree_TM
Joined: 2009-06-30, 22:23
Posts: 2
Ranking
Just found this site
Posted at: 2009-07-01, 09:19

Thanks .... that was it face-smile.png


Top Quote