Currently Online

Latest Posts

Topic: Missing lib

Joined: 2009-03-05, 09:07
Posts: 4
Just found this site
Posted at: 2009-03-05, 09:12


When I try to start the game it says :

maximb@maximb-laptop:~/Games/Widelands-build13$ ./widelands ./widelands: error while loading shared libraries: cannot open shared object file: No such file or directory

I've searched my laptop and I don't have this file.

where do I get it and how do I load it ?

I am using Build 13.

Edited: 2009-03-05, 09:13

Top Quote
Joined: 2009-02-21, 18:17
Posts: 829
One Elder of Players
Location: Germany
Posted at: 2009-03-05, 11:07

What kind of Operatingsystem do you use? If Linux, you should simply try install the "libSDL _ttf" (or perhaps just "SDL _ttf") packages from your distribution. The library is quite common, so I think all bigger linux distributions will serve a version.

Edited: 2009-03-05, 11:07

Top Quote
Joined: 2009-02-27, 02:59
Posts: 39
Pry about Widelands
Posted at: 2009-03-24, 17:48

This sounds like the library that was reported missing every time I tried to compile from source. This also seems to be one of the issues when I tried to build GCC. This is despite the fact that the library existed in all layers of the path. I'm waiting until after I learn more about programming before trying to build from source again!


Top Quote