Latest Posts

Topic: Post bugs which should be fixed in build21

WorldSavior
Avatar
Joined: 2016-10-15, 04:10
Posts: 1257
Ranking
One Elder of Players
Location: GER
Posted at: 2019-09-17, 19:05

Look what happens when I try to enter the lobby unregistered ( I can enter the lobby only with my Forum account) :


Attachment: LobbyBug.png (1.2 MB)

“It's a threat to our planet to believe that someone else will save it.” - Robert Swan

Top Quote
kaputtnik
Avatar
Joined: 2013-02-18, 20:48
Posts: 1765
Ranking
One Elder of Players
Location: Germany
Posted at: 2019-09-17, 20:59

Confirmed


Top Quote
king_of_nowhere
Avatar
Joined: 2014-09-15, 18:35
Posts: 1429
Ranking
One Elder of Players
Posted at: 2019-09-19, 00:55

soorry if I don't read the full long discussion, you're probably already mentioning it, but the bug that caused wares to go amiss and get stuck in flags without getting moved is still in full force as of the version I installed one week ago to playtest amazonians


Top Quote
dubhead2
Avatar
Joined: 2019-09-19, 02:34
Posts: 1
Ranking
Just found this site
Posted at: 2019-09-19, 02:41

> *WorldSavior wrote:*
>
> Look what happens when I try to enter the lobby unregistered ( I can enter the lobby only with my Forum account) :

Just tried it, same problem

but with an registered account it works
(gaming-pw has to be set of course)

edit: ok, now i think you know that already, but just in case for others...


edit2: played a 1on1-game and found another bug:
for some reason after 2h or so, sometimes a soldier wich is nearly fully trained leaves the trainingbuilding just to return a few moments later (and repeats that behaviour several times) (without user interaction)

another thing, if i kick a soldier out of a building, i don't normally want him to immediately return to that same building (esp. if i kick him out of training and there are open military-sites)
would be nice to be able to sort your soldiers into the preferred buildings without to much hassle

and another thing, i think there is a bug in the conquered/lost building-statistics, it always showed the same numbers for both players, even if one of them didn't loose a single building
(playing bzr9203 on debian-testing)

other than that, i'm impressed by the progress you made! awesome work from u all! give thanks!

Edited: 2019-09-19, 07:21

Top Quote
kaputtnik
Avatar
Joined: 2013-02-18, 20:48
Posts: 1765
Ranking
One Elder of Players
Location: Germany
Posted at: 2019-09-19, 08:15

king_of_nowhere wrote:

soorry if I don't read the full long discussion, you're probably already mentioning it, but the bug that caused wares to go amiss and get stuck in flags without getting moved is still in full force as of the version I installed one week ago to playtest amazonians

See https://github.com/widelands/widelands/issues/3440 and https://github.com/widelands/widelands/issues/1085

dubhead2 wrote:

edit2: played a 1on1-game and found another bug: for some reason after 2h or so, sometimes a soldier wich is nearly fully trained leaves the trainingbuilding just to return a few moments later (and repeats that behaviour several times) (without user interaction)

See https://github.com/widelands/widelands/issues/1663

another thing, if i kick a soldier out of a building, i don't normally want him to immediately return to that same building (esp. if i kick him out of training and there are open military-sites) would be nice to be able to sort your soldiers into the preferred buildings without to much hassle

I guess in that case you haven't enough soldiers to fill all military buildings and the kicked soldier just goes to the nearest military building again. I wouldn't consider this a bug, just decrease the number of soldiers in the building where you kicked him.

and another thing, i think there is a bug in the conquered/lost building-statistics, it always showed the same numbers for both players, even if one of them didn't loose a single building (playing bzr9203 on debian-testing)

Can someone else confirm this?


Top Quote
stonerl
Avatar
Joined: 2018-07-30, 00:03
Posts: 220
Ranking
Widelands-Forum-Junkie
Location: Earth
Posted at: 2019-09-19, 08:48

kaputtnik wrote:

and another thing, i think there is a bug in the conquered/lost building-statistics, it always showed the same numbers for both players, even if one of them didn't loose a single building (playing bzr9203 on debian-testing)

Can someone else confirm this?

https://github.com/widelands/widelands/issues/3390


Top Quote
GunChleoc
Avatar
Joined: 2013-10-07, 15:56
Posts: 3057
Ranking
One Elder of Players
Location: RenderedRect
Posted at: 2019-09-19, 14:21

dubhead2, welcome to the forum and thanks for reporting!

The multiplayer login crash was fixed today face-smile.png

Edited: 2019-09-19, 14:21

Busy indexing nil values

Top Quote