Latest Posts

Topic: Production site statistics

Astuur
Avatar
Joined: 2009-02-28, 10:08
Posts: 733
Ranking
One Elder of Players
Location: Frankfurt / Germany
Posted at: 2009-04-06, 08:40

I am not quite happy with the way the statistics is done.

Too often (especially for mines) 0% is displayed, when you can clearly see resources transported from the site.

Also the readouts values jump very widely due to one single incident. (one iron ore mined gives you 0%->30%->50%->20% ->0%)

It may be a question of adjusting the time window used for calculating the averaged statistic (seems too short)

Also, I do not understand why the display is only adjusted in steps of 10%. This was probably done to avoid the constant change of numbers, but it still often flickers between two values. Maybe with a larger time base the rounding could be passed and we could have exact full percentages (but no decimals) instead?

Another thing is that the English version shows UP/ DOWN next to the percentage, while the German one has +/- (which is less intrusive)


Being no programmer, I apologize for all my suggestions that imply undue workload and for other misjudgements due to lack of expertise or relevant skills.
I am on Win32, have no means to compile, and rely on prefabricated distributions (Thanks to Tino).

Top Quote
Scraggy
Joined: 2009-04-01, 14:15
Posts: 4
Ranking
Just found this site
Posted at: 2009-05-19, 14:44

I agree - looking at the source, it seems that the statistics are incorrectly calculated.


Top Quote