Latest Posts

Topic: strange carrier behaviour

Ron_of_Nord
Avatar
Topic Opener
Joined: 2024-04-20, 22:43
Posts: 19
OS: Windows
Version: 1.2rc1
Ranking
Pry about Widelands
Location: Land_down_under
Posted at: 2024-06-13, 12:13

I have noticed something strange with the barbarians and cannot figure this one out. Sometimes a road gets assigned 2 carriers, not 1 carrier and an ox which works fine, but 2 human carriers. this happens mostly when a road is accidently removed and immediately replaced, the original carrier stays on the road and a new one arrives (eventually) as well. I have been able to reproduce this multiple times after testing, so I wonder what is going on. I scanned the source code but couldnt find anything that would trigger this. I am playing version 1.2 on windows and I also have the source code for that version.

Any thoughts on this would be welcome.


The aussies are coming, ya ho! ya ho!

Top Quote
kaputtnik
Avatar
Joined: 2013-02-18, 19:48
Posts: 2480
OS: Archlinux
Version: current master
Ranking
One Elder of Players
Location: Germany
Posted at: 2024-06-13, 15:01

There is already a bug report open for this behavior: https://github.com/widelands/widelands/issues/5998

What might happen is that by building a new road a new carrier is requested from a warehouse, while the old carrier is still connected with the road. But this is just a guess, i do not know how the requests for carriers are handled.


Fight simulator for Widelands:
https://wide-fighter.netlify.app/

Top Quote
Ron_of_Nord
Avatar
Topic Opener
Joined: 2024-04-20, 22:43
Posts: 19
OS: Windows
Version: 1.2rc1
Ranking
Pry about Widelands
Location: Land_down_under
Posted at: 2024-06-14, 00:37

Thanks for the reply, i'll check out the bug report when I get a moment to spare. I didn't see the bug report last night. This insn't a really bad issue as far as I can tell, just a quirk which admittedly makes me laugh at times, it certainly is entertaining at times!


The aussies are coming, ya ho! ya ho!

Top Quote