Latest Posts

Topic: Widelands 1.1 & 1.0 saves

mxb2001
Avatar
Topic Opener
Joined: 2019-05-20, 18:49
Posts: 237
OS: Linux
Version: 1.1
Ranking
Widelands-Forum-Junkie
Location: The land of the thirsty spider
Posted at: 2023-06-06, 06:52

So, spurred by WL 1.1 I finally moved to Debian 10 and now can install WL 1.1 (well actually stupid me assumed it needed the new flatpak runtime that didn't work in Deb9 like with Wesnoth flatpak but that may have not been the case I saw when I actually checked... urgh) but I have some nice 1.0 games saved that I wanna finish and was wondering if 1.1 can load 1.0's similarly to how I think 1.0 could load b21?

So should I wait to finish my games in 1.0 or can I move to 1.1 and finish them with it?


--
To Boldly Go Where No Man Has Gone Before

Top Quote
Nordfriese
Avatar
Joined: 2017-01-17, 18:07
Posts: 1916
OS: Debian Unstable
Version: Latest master
Ranking
One Elder of Players
Location: 0x55555d3a34c0
Posted at: 2023-06-06, 10:57

Yes, all 1.x savegames can be loaded with the next version 1.(x+1).

It's an explicit development aim not to break savegame and API compatibility between successive versions; if we ever have to do that again then the next version would be called 2.0.

Compatibility is only guaranteed from each release to the next, so it won't be possible to load build21 saves in v1.1 or v1.0 saves in v1.2.


Top Quote
mxb2001
Avatar
Topic Opener
Joined: 2019-05-20, 18:49
Posts: 237
OS: Linux
Version: 1.1
Ranking
Widelands-Forum-Junkie
Location: The land of the thirsty spider
Posted at: 2023-06-06, 21:25

Awesome, thanks. 1.1 here I come!


--
To Boldly Go Where No Man Has Gone Before

Top Quote
knarf
Avatar
Joined: 2024-01-03, 21:20
Posts: 37
OS: Debian
Ranking
Pry about Widelands
Posted at: 2024-01-04, 11:44

mxb2001 wrote:

So, spurred by WL 1.1 I finally moved to Debian 10 and now can install WL 1.1

You did write this in 2023, where Debian 12 is 'stable', and best of all: contains a WL 1.1 native Debian package. You could move up to that. face-smile.png


Top Quote
mxb2001
Avatar
Topic Opener
Joined: 2019-05-20, 18:49
Posts: 237
OS: Linux
Version: 1.1
Ranking
Widelands-Forum-Junkie
Location: The land of the thirsty spider
Posted at: 2024-01-04, 22:06

knarf wrote:

mxb2001 wrote:

So, spurred by WL 1.1 I finally moved to Debian 10 and now can install WL 1.1

You did write this in 2023, where Debian 12 is 'stable', and best of all: contains a WL 1.1 native Debian package. You could move up to that. face-smile.png

It's 2024 and I'm still on Deb 10. : ) I had some grand plans on trying to catch up faster by installing 11 after a few months but that didn't happen. Anyways, 11 is as far as I'd likely go until 12 gets to something like say 12.5 or so.

In any case I've now grown into flatpak and since I made the effort to figure it out a little I'll use it. It's really a good choice for Debian which rarely has up to date games. Oddly though 12 not only has the current widelands it even has the current wesnoth. I think it's just chance though.


--
To Boldly Go Where No Man Has Gone Before

Top Quote