Latest Posts

Topic: problem with display

wollewuu
Avatar
Topic Opener
Joined: 2023-03-23, 17:10
Posts: 6
Ranking
Pry about Widelands
Posted at: 2023-03-23, 17:13

Hello together,

I install the 1.1 version. As I try to start I get a screen with green lines. Unfortunatley it´s unable to play with it? Do you have expaeriace with that before?

Best Regards Wollewuu


Top Quote
Nordfriese
Avatar
Joined: 2017-01-17, 17:07
Posts: 1974
OS: Debian Testing
Version: Latest master
Ranking
One Elder of Players
Location: 0x55555d3a34c0
Posted at: 2023-03-23, 18:02

Hi Wollewuu and welcome to the forum face-smile.png

To help diagnose the problem, please tell us which operating system you use, and post the log output that you get when starting Widelands from a terminal (instructions in case you use Windows).


Top Quote
kaputtnik
Avatar
Joined: 2013-02-18, 19:48
Posts: 2456
OS: Archlinux
Version: current master
Ranking
One Elder of Players
Location: Germany
Posted at: 2023-03-23, 18:03

Hi wollewuu and welcome to the forums face-smile.png

Unfortunately some video graphics driver do have problems with OpenGl. I guess your are using an Intel graphics card, but please provide your graphics card and the used OS (e.g. Windows or Linux). Depending on your OS you should also provide some output:

  • Linux: Start widelands from the command line, this should give some information about your graphics
  • Windows: Please search for file named `stdout.txt', this should contain also some information

Fight simulator for Widelands:
https://wide-fighter.netlify.app/

Top Quote
wollewuu
Avatar
Topic Opener
Joined: 2023-03-23, 17:10
Posts: 6
Ranking
Pry about Widelands
Posted at: 2023-03-24, 14:15

Hello together,

i use windows11 @Nordfriese I try the way that you had told me. I get this result.

This is Widelands version 1.1 Release

[00:00:00.000 real] INFO: Set home directory: C:\Users\User.widelands

[00:00:00.000 real] INFO: Set configuration file: C:\Users\User.widelands\config

[00:00:00.000 real] INFO: Widelands executable directory: C:\Users\User\AppData\Local\Widelands

[00:00:00.001 real] WARNING: No locale translations found in C:\Users\User\AppData\Local\Widelands\data\locale

[00:00:00.002 real] INFO: selected language: (system language)

[00:00:00.007 real] INFO: Adding directory: C:\Users\User\AppData\Local\Widelands\data

[00:00:00.007 real] WARNING: No locale translations found in C:\Users\User\AppData\Local\Widelands\data\locale

[00:00:00.008 real] INFO: selected language: (system language)

[00:00:00.015 real] INFO: Byte order: little-endian

[00:00:00.146 real] INFO: Graphics: Try to set Videomode 800x600

[00:00:00.212 real] INFO: Graphics: OpenGL: Version "4.6.0 - Build 27.20.100.8280"

[00:00:00.214 real] INFO: Graphics: SDL_GL_RED_SIZE is 10

[00:00:00.214 real] INFO: Graphics: SDL_GL_GREEN_SIZE is 10

[00:00:00.214 real] INFO: Graphics: SDL_GL_BLUE_SIZE is 10

[00:00:00.214 real] INFO: Graphics: SDL_GL_ALPHA_SIZE is 2

[00:00:00.214 real] INFO: Graphics: SDL_GL_BUFFER_SIZE is 32

[00:00:00.214 real] INFO: Graphics: SDL_GL_DOUBLEBUFFER is 1

[00:00:00.214 real] INFO: Graphics: SDL_GL_DEPTH_SIZE is 24

[00:00:00.214 real] INFO: Graphics: SDL_GL_STENCIL_SIZE is 8

[00:00:00.214 real] INFO: Graphics: SDL_GL_ACCUM_RED_SIZE is 0

[00:00:00.214 real] INFO: Graphics: SDL_GL_ACCUM_GREEN_SIZE is 0

[00:00:00.214 real] INFO: Graphics: SDL_GL_ACCUM_BLUE_SIZE is 0

[00:00:00.214 real] INFO: Graphics: SDL_GL_ACCUM_ALPHA_SIZE is 0

[00:00:00.214 real] INFO: Graphics: SDL_GL_STEREO is 0

[00:00:00.214 real] INFO: Graphics: SDL_GL_MULTISAMPLEBUFFERS is 0

[00:00:00.214 real] INFO: Graphics: SDL_GL_MULTISAMPLESAMPLES is 0

[00:00:00.214 real] INFO: Graphics: SDL_GL_ACCELERATED_VISUAL is 1

[00:00:00.214 real] INFO: Graphics: SDL_GL_CONTEXT_MAJOR_VERSION is 2

[00:00:00.214 real] INFO: Graphics: SDL_GL_CONTEXT_MINOR_VERSION is 1

[00:00:00.214 real] INFO: Graphics: SDL_GL_CONTEXT_FLAGS is 0

[00:00:00.214 real] INFO: Graphics: SDL_GL_CONTEXT_PROFILE_MASK is 0

[00:00:00.214 real] INFO: Graphics: SDL_GL_SHARE_WITH_CURRENT_CONTEXT is 0

[00:00:00.214 real] INFO: Graphics: SDL_GL_FRAMEBUFFER_SRGB_CAPABLE is 0

[00:00:00.214 real] INFO: Graphics: OpenGL: Double buffering enabled

[00:00:00.214 real] INFO: Graphics: OpenGL: Max texture size: 16384

[00:00:00.214 real] INFO: Graphics: OpenGL: ShadingLanguage: "4.60 - Build 27.20.100.8280"

[00:00:00.221 real] INFO: * GRAPHICS REPORT *

[00:00:00.221 real] INFO: VIDEO DRIVER windows

[00:00:00.221 real] INFO: Display #0: 1920x1080 @ 59hz SDL_PIXELFORMAT_RGB888

[00:00:00.221 real] INFO: Display #1: 1920x1080 @ 60hz SDL_PIXELFORMAT_RGB888

[00:00:00.723 real] INFO: * SOUND REPORT *

[00:00:00.723 real] INFO: SDL version: 2.24.1

[00:00:00.723 real] INFO: SDL_mixer version: 2.6.2

[00:00:00.723 real] INFO: * END SOUND REPORT *

[00:00:01.240 real] INFO: Songset: Loaded song "music\intro.ogg"

[00:00:01.651 real] INFO: Songset: Loaded song "music\menu.ogg"

[00:00:03.825 real] INFO: SoundHandler: Closing 1 time, 48000 Hz, format 32784, 2 channels

[00:00:03.826 real] INFO: SoundHandler: SDL_AUDIODRIVER wasapi

do you have the possibility to work with it?


Top Quote
Nordfriese
Avatar
Joined: 2017-01-17, 17:07
Posts: 1974
OS: Debian Testing
Version: Latest master
Ranking
One Elder of Players
Location: 0x55555d3a34c0
Posted at: 2023-03-24, 14:47

Thanks, this clarifies things. The interesting part is this:

[00:00:00.214 real] INFO: Graphics: SDL_GL_RED_SIZE is 10
[00:00:00.214 real] INFO: Graphics: SDL_GL_GREEN_SIZE is 10
[00:00:00.214 real] INFO: Graphics: SDL_GL_BLUE_SIZE is 10
[00:00:00.214 real] INFO: Graphics: SDL_GL_ALPHA_SIZE is 2
[00:00:00.214 real] INFO: Graphics: SDL_GL_BUFFER_SIZE is 32

My installation shows:

[00:00:00.229 real] INFO: Graphics: SDL_GL_RED_SIZE is 8
[00:00:00.229 real] INFO: Graphics: SDL_GL_GREEN_SIZE is 8
[00:00:00.229 real] INFO: Graphics: SDL_GL_BLUE_SIZE is 8
[00:00:00.229 real] INFO: Graphics: SDL_GL_ALPHA_SIZE is 0
[00:00:00.230 real] INFO: Graphics: SDL_GL_BUFFER_SIZE is 24

This means that your graphics driver expects colour values with 32 bits, of which 10 each are for the R,G,B components and 2 for the A component; while my driver uses the more common 24-bit layout with 8,8,8,0 bits for the components.

I can't test this directly since it's driver-specific, but I'll look into it this weekend…


Top Quote
wollewuu
Avatar
Topic Opener
Joined: 2023-03-23, 17:10
Posts: 6
Ranking
Pry about Widelands
Posted at: 2023-03-24, 14:52

Super danke das ist sehr nett! face-smile.png


Top Quote
Nordfriese
Avatar
Joined: 2017-01-17, 17:07
Posts: 1974
OS: Debian Testing
Version: Latest master
Ranking
One Elder of Players
Location: 0x55555d3a34c0
Posted at: 2023-03-24, 19:51

Could you please install the following modified version and see if this changes anything:
https://github.com/Noordfrees/widelands/releases/download/5761_opengl_bit_layout/Widelands-2c6796b0f17e0e0a66cc1b78235380076369917e-mingw-Release-x64.exe

If this doesn't fix it, please again attach the log output this one gives you, and also a screenshot of the problem (after you have written 5 posts you can add attachments to your posts).


Top Quote
wollewuu
Avatar
Topic Opener
Joined: 2023-03-23, 17:10
Posts: 6
Ranking
Pry about Widelands
Posted at: 2023-03-25, 05:52

Dear Nordfriese,

it doesn´t work face-confused.png

his is Widelands version 1.2~git1 (2c6796b@opengl-bit-layout) Release

[00:00:00.000 real] INFO: Set home directory: C:\Users\User.widelands

[00:00:00.000 real] INFO: Set configuration file: C:\Users\User.widelands\config

[00:00:00.000 real] INFO: Widelands executable directory: C:\Users\User\AppData\Local\Widelands\Widelands

[00:00:00.001 real] WARNING: No locale translations found in C:\Users\User\AppData\Local\Widelands\Widelands\data\locale

[00:00:00.003 real] INFO: selected language: (system language)

[00:00:00.009 real] INFO: Adding directory: C:\Users\User\AppData\Local\Widelands\Widelands\data

[00:00:00.009 real] WARNING: No locale translations found in C:\Users\User\AppData\Local\Widelands\Widelands\data\locale

[00:00:00.009 real] INFO: selected language: (system language)

[00:00:00.017 real] INFO: Byte order: little-endian

[00:00:00.188 real] INFO: Graphics: Try to set Videomode 800x600

[00:00:00.257 real] INFO: Graphics: OpenGL: Version "4.6.0 - Build 27.20.100.8280"

[00:00:00.258 real] INFO: Graphics: SDL_GL_RED_SIZE is 10

[00:00:00.258 real] INFO: Graphics: SDL_GL_GREEN_SIZE is 10

[00:00:00.258 real] INFO: Graphics: SDL_GL_BLUE_SIZE is 10

[00:00:00.258 real] INFO: Graphics: SDL_GL_ALPHA_SIZE is 2

[00:00:00.258 real] INFO: Graphics: SDL_GL_BUFFER_SIZE is 32

[00:00:00.258 real] INFO: Graphics: SDL_GL_DOUBLEBUFFER is 1

[00:00:00.258 real] INFO: Graphics: SDL_GL_DEPTH_SIZE is 24

[00:00:00.258 real] INFO: Graphics: SDL_GL_STENCIL_SIZE is 8

[00:00:00.258 real] INFO: Graphics: SDL_GL_ACCUM_RED_SIZE is 0

[00:00:00.259 real] INFO: Graphics: SDL_GL_ACCUM_GREEN_SIZE is 0

[00:00:00.259 real] INFO: Graphics: SDL_GL_ACCUM_BLUE_SIZE is 0

[00:00:00.259 real] INFO: Graphics: SDL_GL_ACCUM_ALPHA_SIZE is 0

[00:00:00.259 real] INFO: Graphics: SDL_GL_STEREO is 0

[00:00:00.259 real] INFO: Graphics: SDL_GL_MULTISAMPLEBUFFERS is 0

[00:00:00.259 real] INFO: Graphics: SDL_GL_MULTISAMPLESAMPLES is 0

[00:00:00.259 real] INFO: Graphics: SDL_GL_ACCELERATED_VISUAL is 1

[00:00:00.259 real] INFO: Graphics: SDL_GL_CONTEXT_MAJOR_VERSION is 2

[00:00:00.259 real] INFO: Graphics: SDL_GL_CONTEXT_MINOR_VERSION is 1

[00:00:00.259 real] INFO: Graphics: SDL_GL_CONTEXT_FLAGS is 0

[00:00:00.259 real] INFO: Graphics: SDL_GL_CONTEXT_PROFILE_MASK is 0

[00:00:00.259 real] INFO: Graphics: SDL_GL_SHARE_WITH_CURRENT_CONTEXT is 0

[00:00:00.259 real] INFO: Graphics: SDL_GL_FRAMEBUFFER_SRGB_CAPABLE is 0

[00:00:00.259 real] INFO: Graphics: OpenGL: Double buffering enabled

[00:00:00.259 real] INFO: Graphics: OpenGL: Max texture size: 16384

[00:00:00.259 real] INFO: Graphics: OpenGL: ShadingLanguage: "4.60 - Build 27.20.100.8280"

[00:00:00.263 real] INFO: * GRAPHICS REPORT *

[00:00:00.263 real] INFO: VIDEO DRIVER windows

[00:00:00.263 real] INFO: Display #0: 1920x1080 @ 59hz SDL_PIXELFORMAT_RGB888

[00:00:00.263 real] INFO: Display #1: 1920x1080 @ 60hz SDL_PIXELFORMAT_RGB888

[00:00:01.441 real] INFO: * SOUND REPORT *

[00:00:01.441 real] INFO: SDL version: 2.26.4

[00:00:01.441 real] INFO: SDL_mixer version: 2.6.3

[00:00:01.441 real] INFO: * END SOUND REPORT *

[00:00:02.341 real] INFO: Songset: Loaded song "music\intro.ogg"

[00:00:02.749 real] INFO: Songset: Loaded song "music\menu.ogg"

[00:00:07.058 real] INFO: SoundHandler: Closing 1 time, 44100 Hz, format 32784, 2 channels

[00:00:07.058 real] INFO: SoundHandler: SDL_AUDIODRIVER wasapi

thank you for your help the failure is still there


Top Quote
Nordfriese
Avatar
Joined: 2017-01-17, 17:07
Posts: 1974
OS: Debian Testing
Version: Latest master
Ranking
One Elder of Players
Location: 0x55555d3a34c0
Posted at: 2023-03-26, 10:52

Okay, next try:
https://github.com/Noordfrees/widelands/releases/download/5761_opengl_bit_layout/Widelands-1fee9c8c91f9b35211011e36a7279b8f82e1e3e7-mingw-Release-x64.exe

Maybe this fixes it, or maybe it won't even start. In any case it has additional logging output that will help to diagnose the problem.

If this doesn't fix it I'll need a screenshot of the problem to further troubleshoot it.


Top Quote
wollewuu
Avatar
Topic Opener
Joined: 2023-03-23, 17:10
Posts: 6
Ranking
Pry about Widelands
Posted at: 2023-04-06, 18:57

Hello,

so the output is

This is Widelands version 1.2~git1 (1fee9c8@opengl-bit-layout) Release

[00:00:00.000 real] INFO: Set home directory: C:\Users\User.widelands

[00:00:00.000 real] INFO: Set configuration file: C:\Users\User.widelands\config

[00:00:00.002 real] INFO: Widelands executable directory: C:\Users\User\AppData\Local\Widelands

[00:00:00.004 real] WARNING: No locale translations found in C:\Users\User\AppData\Local\Widelands\data\locale

[00:00:00.006 real] INFO: selected language: (system language)

[00:00:00.014 real] INFO: Setting initializer thread.

[00:00:00.015 real] INFO: Adding directory: C:\Users\User\AppData\Local\Widelands\data

[00:00:00.015 real] WARNING: No locale translations found in C:\Users\User\AppData\Local\Widelands\data\locale

[00:00:00.016 real] INFO: selected language: (system language)

[00:00:00.032 real] INFO: Byte order: little-endian

[00:00:00.167 real] INFO: Graphics: Try to set Videomode 800x600

[00:00:00.232 real] INFO: Graphics: OpenGL: Version "4.6.0 - Build 27.20.100.8280"

[00:00:00.232 real] INFO: Graphics: SDL_GL_RED_SIZE is 10

[00:00:00.232 real] INFO: Graphics: SDL_GL_GREEN_SIZE is 10

[00:00:00.232 real] INFO: Graphics: SDL_GL_BLUE_SIZE is 10

[00:00:00.233 real] INFO: Graphics: SDL_GL_ALPHA_SIZE is 2

[00:00:00.233 real] INFO: Graphics: SDL_GL_BUFFER_SIZE is 32

[00:00:00.233 real] INFO: Graphics: SDL_GL_DOUBLEBUFFER is 1

[00:00:00.233 real] INFO: Graphics: SDL_GL_DEPTH_SIZE is 24

[00:00:00.233 real] INFO: Graphics: SDL_GL_STENCIL_SIZE is 8

[00:00:00.233 real] INFO: Graphics: SDL_GL_ACCUM_RED_SIZE is 0

[00:00:00.233 real] INFO: Graphics: SDL_GL_ACCUM_GREEN_SIZE is 0

[00:00:00.233 real] INFO: Graphics: SDL_GL_ACCUM_BLUE_SIZE is 0

[00:00:00.233 real] INFO: Graphics: SDL_GL_ACCUM_ALPHA_SIZE is 0

[00:00:00.233 real] INFO: Graphics: SDL_GL_STEREO is 0

[00:00:00.233 real] INFO: Graphics: SDL_GL_MULTISAMPLEBUFFERS is 0

[00:00:00.233 real] INFO: Graphics: SDL_GL_MULTISAMPLESAMPLES is 0

[00:00:00.233 real] INFO: Graphics: SDL_GL_ACCELERATED_VISUAL is 1

[00:00:00.233 real] INFO: Graphics: SDL_GL_CONTEXT_MAJOR_VERSION is 2

[00:00:00.233 real] INFO: Graphics: SDL_GL_CONTEXT_MINOR_VERSION is 1

[00:00:00.233 real] INFO: Graphics: SDL_GL_CONTEXT_FLAGS is 0

[00:00:00.233 real] INFO: Graphics: SDL_GL_CONTEXT_PROFILE_MASK is 0

[00:00:00.233 real] INFO: Graphics: SDL_GL_SHARE_WITH_CURRENT_CONTEXT is 0

[00:00:00.233 real] INFO: Graphics: SDL_GL_FRAMEBUFFER_SRGB_CAPABLE is 0

[00:00:00.233 real] INFO: Graphics: OpenGL: Double buffering enabled

[00:00:00.233 real] INFO: Graphics: OpenGL: Max texture size: 16384

[00:00:00.233 real] INFO: Graphics: OpenGL: ShadingLanguage: "4.60 - Build 27.20.100.8280"

[00:00:00.236 real] INFO: * GRAPHICS REPORT *

[00:00:00.236 real] INFO: VIDEO DRIVER windows

[00:00:00.236 real] INFO: Display #0: 1920x1080 @ 60hz 24bpp SDL_PIXELFORMAT_RGB888

[00:00:00.236 real] INFO: * END GRAPHICS REPORT *

[00:00:00.236 real] INFO: Rebuilding texture atlas

it doesn´t start at all with this version.

I install the second version. I try to add a screenshot for show the problem


Top Quote