Latest Posts

Topic: Fehler bei installation

waldecker
Avatar
Joined: 2020-05-31, 21:15
Posts: 70
Ranking
Likes to be here
Location: Waldeck
Posted at: 2022-08-11, 16:04

Hallo zusammen,

habe heute meinen Laptop neu aufgesetzt mit Kubuntu 22.04, beim installieren von Widelands wird eine nicht installierbare Library (libicu67) gefordert, weiß jemand in welcher Packetquelle (gesicherten) ich die lib finde? Bei debian.org finde ich zwar die lib, aber der Rechner meckert das die Verbindung nicht verschlüsselt ist.

~$ sudo apt-get update
OK:1 http://ppa.launchpad.net/widelands-dev/widelands/ubuntu jammy InRelease
OK:2 https://linux.teamviewer.com/deb stable InRelease                                                       
OK:3 https://mirrors.tuxedocomputers.com/ubuntu/mirror/archive.ubuntu.com/ubuntu jammy InRelease             
OK:4 https://deb.tuxedocomputers.com/ubuntu jammy InRelease                                                        
OK:5 https://mirrors.tuxedocomputers.com/ubuntu/mirror/archive.ubuntu.com/ubuntu jammy-updates InRelease
OK:6 https://mirrors.tuxedocomputers.com/ubuntu/mirror/security.ubuntu.com/ubuntu jammy-security InRelease
Paketlisten werden gelesen… Fertig

~$ sudo apt-get install widelands
Paketlisten werden gelesen… Fertig
Abhängigkeitsbaum wird aufgebaut… Fertig
Statusinformationen werden eingelesen… Fertig
Einige Pakete konnten nicht installiert werden. Das kann bedeuten, dass
Sie eine unmögliche Situation angefordert haben oder, wenn Sie die
Unstable-Distribution verwenden, dass einige erforderliche Pakete noch
nicht erstellt wurden oder Incoming noch nicht verlassen haben.
Die folgenden Informationen helfen Ihnen vielleicht, die Situation zu lösen:

Die folgenden Pakete haben unerfüllte Abhängigkeiten:
 widelands : Hängt ab von: libicu67 (>= 67.1-1~) ist aber nicht installierbar
E: Probleme können nicht korrigiert werden, Sie haben zurückgehaltene defekte Pakete.


Yesterday I stood before an abyss, today I'm one step further

Top Quote
kaputtnik
Avatar
Joined: 2013-02-18, 20:48
Posts: 2182
Ranking
One Elder of Players
Location: Germany
Posted at: 2022-08-11, 19:08

Servus,

hast Du schon probiert das Paket libicu70 zu installieren um das Problem zu beheben?

Ich denke die Angabe (>= 67.1-1~) sollte icu70 mit einschließen, aber ich bin kein Paketprofi.


Wir sind alle nur chemische Marionetten,
hängen an Desoxyribonukleinsäureketten.

Jazzkantine - Alles nur Chemie

Top Quote
waldecker
Avatar
Joined: 2020-05-31, 21:15
Posts: 70
Ranking
Likes to be here
Location: Waldeck
Posted at: 2022-08-11, 19:14

libicu70 ist bereits installiert, Fehlermeldung beim Versuch Widelands zu installieren bleibt die gleiche

Edited: 2022-08-11, 19:15

Yesterday I stood before an abyss, today I'm one step further

Top Quote
Nordfriese
Avatar
Joined: 2017-01-17, 18:07
Posts: 1660
Ranking
One Elder of Players
Location: 0x55555d3a34c0
Posted at: 2022-08-11, 21:29

Autsch, Jammy + ICU = große Schwierigkeiten … face-wink.png

Du könntest versuchen, ob das Installieren von libicu-dev Abhilfe schafft. Wenn das nichts bringt, verwende besser das Flatpak-Paket.

ICU hat die unschöne Angewohnheit, die Paketversion in den Paketnamen zu schreiben. icu67 und icu70 sind also zwei unterschiedliche Pakete, die nicht gegeneinander austauschbar sind. icu67 ist für Impish verfügbar, icu70 für Jammy. Dazu kommt, dass Jammy in Bezug auf seine Paketquellen einen riesigen Schritt rückwärts darstellt; viele Programme, die unter Impish tadellos funktionert haben, installieren oder starten unter Jammy nicht mehr. Wenn Kinetic das nicht behebt werde ich auf eine andere Distro umsteigen. Normalerweise halte ich ja native Pakete gegenüber Snap/Flatpak für überlegen, aber hier bieten letztere eine nützliche Alternative.


Top Quote