Latest Posts

Topic: Empire03 bug or intentional?

tothxa
Avatar
Joined: 2021-03-24, 12:44
Posts: 50
Ranking
Likes to be here
Posted at: 2021-04-24, 02:06

In the 3rd scenario of the Empire campaign, the spot on the map that is shown during the intro and then hidden can't be revealed again during the game. The hidden area also contains one of the artifacts which are needed to win the scenario, so this may hinder some players. But that may be an intentional logical challenge...

I was able to find that the scenario's mission_thread.lua calls the function hide_randomly in data/scripting/field_animations.lua, which in turn calls the LuaPlayer::hide_fields method in src/scripting/lua_game.cc, but I don't understand the C++ code for selecting between kHide and kUnreveal, and how to pass an argument to affect it, and I wasn't able to figure out how these values work anyway.

There is a constant True value passed by hide_randomly to ::hide_fields, but if I change it to False, it causes the area to remain revealed.

Edited: 2021-04-24, 08:30

Top Quote
kaputtnik
Avatar
Joined: 2013-02-18, 20:48
Posts: 2044
Ranking
One Elder of Players
Location: Germany
Posted at: 2021-04-24, 08:41

Yes, this is known and currently a showstopper for version1.

There is also a pull request for a quickfix for this issue but no one get around to verify this.


Top Quote
tothxa
Avatar
Joined: 2021-03-24, 12:44
Posts: 50
Ranking
Likes to be here
Posted at: 2021-04-24, 11:29

Oh, sorry! I searched for it here in the forums, but not on github...


Top Quote