Latest Posts

Topic: Game Crash (actual master build with Europeans)

MarkMcWire
Avatar
Joined: 2017-02-08, 21:06
Posts: 297
Ranking
Tribe Member
Location: Eisenach, Germany
Posted at: 2020-12-09, 22:59
widelands: ../src/logic/map_objects/bob.h:301: Widelands::Bob::State& Widelands::Bob::top_state(): Zusicherung »stack_.size()« nicht erfüllt.
Abgebrochen (Speicherabzug geschrieben)


See savegame in Attachments.

Attachment: wl_autosave_00.wgf (2.7 MB)

My widelands project: https://github.com/widelands/wl_addons_server/tree/master/addons/europeans_tribe.wad

Top Quote
kaputtnik
Avatar
Joined: 2013-02-18, 20:48
Posts: 2107
Ranking
One Elder of Players
Location: Germany
Posted at: 2020-12-10, 08:03

This should have been fixed...

Was this an older savegame? According to the version in the save game it was created with version [0511c3c@master] (Debug).


Top Quote
MarkMcWire
Avatar
Joined: 2017-02-08, 21:06
Posts: 297
Ranking
Tribe Member
Location: Eisenach, Germany
Posted at: 2020-12-10, 21:58

The savegame is from last week. Meanwhile I used git pull twice and ./compile.sh to update my widelands binary to actual master.

The problem only occurs sporadically. The longer you let the game run in a row, the sooner. If I only play a few minutes and interrupt the game, the error doesn't occur.

Edited: 2020-12-10, 22:03

My widelands project: https://github.com/widelands/wl_addons_server/tree/master/addons/europeans_tribe.wad

Top Quote
MarkMcWire
Avatar
Joined: 2017-02-08, 21:06
Posts: 297
Ranking
Tribe Member
Location: Eisenach, Germany
Posted at: 2020-12-20, 23:56
widelands: ../src/logic/map_objects/bob.h:301: Widelands::Bob::State& Widelands::Bob::top_state(): Zusicherung »stack_.size()« nicht erfüllt.
Abgebrochen (Speicherabzug geschrieben)


Last debug text:

[00:00:46.052 real] INFO: TrainingSite::drop_stalled_soldiers: Kicking somebody out.



The problem is still there. Here is a new savegame.
Edited: 2020-12-20, 23:59

Attachment: wl_autosave_00.wgf (2.1 MB)

My widelands project: https://github.com/widelands/wl_addons_server/tree/master/addons/europeans_tribe.wad

Top Quote
MarkMcWire
Avatar
Joined: 2017-02-08, 21:06
Posts: 297
Ranking
Tribe Member
Location: Eisenach, Germany
Posted at: 2020-12-21, 20:07

I opened an issue on Github: https://github.com/widelands/widelands/issues/4570#issue-772395207


My widelands project: https://github.com/widelands/wl_addons_server/tree/master/addons/europeans_tribe.wad

Top Quote
MarkMcWire
Avatar
Joined: 2017-02-08, 21:06
Posts: 297
Ranking
Tribe Member
Location: Eisenach, Germany
Posted at: 2020-12-22, 16:23

After I deleted the forester's houses that contained the fault worker (with empty stack), the game continued to run for 20 hours without any problems.

Now it crashed again with the same error message.


My widelands project: https://github.com/widelands/wl_addons_server/tree/master/addons/europeans_tribe.wad

Top Quote