Latest Posts

Topic: Compiler Errors on Raspbian

DanRasp
Avatar
Joined: 2020-12-01, 19:16
Posts: 9
Ranking
Pry about Widelands
Posted at: 2020-12-06, 09:58

Thanks! meanwhile found out myself too...

so i lowered the memory split and set -j 1 now running, past the point it stopped yesterday - interesting fact: codecheck looks differently now, with checksums shown


Top Quote
DanRasp
Avatar
Joined: 2020-12-01, 19:16
Posts: 9
Ranking
Pry about Widelands
Posted at: 2020-12-06, 15:58

meanwhle after 4 runs with some - long unsigned int vs. unsigned int and - a scripting(?) error in something like wui....a

i finally ended up with this:

[ 51%] Built target wl_tests
Test project /home/pi/Downloads/widelands-build21/build
    Start 1: test_ai
1/5 Test #1: test_ai ..........................***Not Run   0.00 sec
    Start 2: test_economy
2/5 Test #2: test_economy .....................***Not Run   0.00 sec
    Start 3: test_io_filesystem
3/5 Test #3: test_io_filesystem ...............***Not Run   0.00 sec
    Start 4: notifications_test
4/5 Test #4: notifications_test ...............***Failed    0.05 sec
==13815==ASan runtime does not come first in initial library list; you should either link runtime to your application or manually preload it with LD_PRELOAD.

    Start 5: test_scripting
5/5 Test #5: test_scripting ...................***Failed    0.04 sec
==13816==ASan runtime does not come first in initial library list; you should either link runtime to your application or manually preload it with LD_PRELOAD.


0% tests passed, 5 tests failed out of 5

Total Test time (real) =   0.15 sec

The following tests FAILED:
      1 - test_ai (BAD_COMMAND)
      2 - test_economy (BAD_COMMAND)
      3 - test_io_filesystem (BAD_COMMAND)
      4 - notifications_test (Failed)
      5 - test_scripting (Failed)
Errors while running CTest
CMakeFiles/_run_all_tests.dir/build.make:57: die Regel für Ziel „CMakeFiles/_run_all_tests“ scheiterte
make[2]: *** [CMakeFiles/_run_all_tests] Fehler 8
CMakeFiles/Makefile2:99: die Regel für Ziel „CMakeFiles/_run_all_tests.dir/all“ scheiterte
make[1]: *** [CMakeFiles/_run_all_tests.dir/all] Fehler 2
Makefile:138: die Regel für Ziel „all“ scheiterte
make: *** [all] Fehler 2
Edited: 2020-12-09, 09:25

Top Quote
hessenfarmer
Avatar
Joined: 2014-12-11, 23:16
Posts: 2051
Ranking
One Elder of Players
Location: Bavaria
Posted at: 2020-12-06, 16:55

Well, as it complains about ASAN you might use the option to compile without Adresssanitizer. by the way are you compiling a release build or a debug build?


Top Quote
Nordfriese
Avatar
Joined: 2017-01-17, 18:07
Posts: 1506
Ranking
One Elder of Players
Location: 0x55555d3a34c0
Posted at: 2020-12-06, 18:25

Did you do

    sudo ln -s /usr/bin/llvm-symbolizer-3.8 /usr/bin/llvm-symbolizer

This needs to be run once to make ASan work


Top Quote
DanRasp
Avatar
Joined: 2020-12-01, 19:16
Posts: 9
Ranking
Pry about Widelands
Posted at: 2020-12-06, 19:27

no i didn't, now tried, but didn't help, now i run a build without ASan


Top Quote
DanRasp
Avatar
Joined: 2020-12-01, 19:16
Posts: 9
Ranking
Pry about Widelands
Posted at: 2020-12-06, 22:33

a new one appeared:

[ 50%] Linking CXX executable test_ai
/usr/bin/ld:../../logic/map_objects/liblogic_map_objects.a: file format not recognized; treating as linker script
/usr/bin/ld:../../logic/map_objects/liblogic_map_objects.a:1: syntax error
collect2: error: ld returned 1 exit status
src/ai/test/CMakeFiles/test_ai.dir/build.make:558: die Regel für Ziel „src/ai/test/test_ai“ scheiterte
make[2]: *** [src/ai/test/test_ai] Fehler 1
CMakeFiles/Makefile2:6682: die Regel für Ziel „src/ai/test/CMakeFiles/test_ai.dir/all“ scheiterte
make[1]: *** [src/ai/test/CMakeFiles/test_ai.dir/all] Fehler 2
Makefile:138: die Regel für Ziel „all“ scheiterte
make: *** [all] Fehler 2
pi@raspberrypi:~/Downloads/widelands-build21 $
Edited: 2020-12-09, 09:25

Top Quote
GunChleoc
Avatar
Joined: 2013-10-07, 15:56
Posts: 3326
Ranking
One Elder of Players
Location: RenderedRect
Posted at: 2020-12-09, 09:30

You can skip compiling the website binaries and the tests. Try:

./compile.sh -r -w -s -j 1

Delete the build directory first to ensure that you are starting from a clean state.

BTW if you write ~~~~ above and below your code, it will get formatted properly so that we can read it.


Busy indexing nil values

Top Quote