Latest Posts

Topic: Widelands not starting

Lennart_XI
Avatar
Joined: 2018-08-06, 10:17
Posts: 3
Ranking
Just found this site
Posted at: 2018-08-06, 10:25

Hey guys, I tried to dl Widelands on my old Windows Laptop. It installed normally, but when I try to start it only a small window pops up, getting closed after 3 sec. My PC specs: Win 7 64 Bit Intel Centrino Pro Interner Grafikchip : Mobile Intel(R) 965 Express Chipset Family Thx for youre help LG Lennart


Top Quote
ypopezios
Avatar
Joined: 2018-04-20, 00:22
Posts: 220
Ranking
Widelands-Forum-Junkie
Posted at: 2018-08-06, 11:12

Welcome, could you share the contents of file stdout.txt in Widelands' directory? Also check this thread: https://wl.widelands.org/forum/topic/4237


Top Quote
Lennart_XI
Avatar
Joined: 2018-08-06, 10:17
Posts: 3
Ranking
Just found this site
Posted at: 2018-08-06, 11:16

This is Widelands Version build-19 (Release) Set home directory: C:\Users\christoph krauch.widelands There's no configuration file, using default values. Widelands executable directory: C:\bin\Widelands Adding directory: C:\bin\Widelands\data selected language: (system language) Could not read locale fontset for: ga Graphics: Try to set Videomode 800x600 Graphics: OpenGL: Version "2.0.0 - Build 8.14.10.1930" Graphics: SDL_GL_RED_SIZE is 8 Graphics: SDL_GL_GREEN_SIZE is 8 Graphics: SDL_GL_BLUE_SIZE is 8 Graphics: SDL_GL_ALPHA_SIZE is 8 Graphics: SDL_GL_BUFFER_SIZE is 32 Graphics: SDL_GL_DOUBLEBUFFER is 1 Graphics: SDL_GL_DEPTH_SIZE is 16 Graphics: SDL_GL_STENCIL_SIZE is 0 Graphics: SDL_GL_ACCUM_RED_SIZE is 16 Graphics: SDL_GL_ACCUM_GREEN_SIZE is 16 Graphics: SDL_GL_ACCUM_BLUE_SIZE is 16 Graphics: SDL_GL_ACCUM_ALPHA_SIZE is 16 Graphics: SDL_GL_STEREO is 0 Graphics: SDL_GL_MULTISAMPLEBUFFERS is 0 Graphics: SDL_GL_MULTISAMPLESAMPLES is 0 Graphics: SDL_GL_ACCELERATED_VISUAL is 1 Graphics: SDL_GL_CONTEXT_MAJOR_VERSION is 2 Graphics: SDL_GL_CONTEXT_MINOR_VERSION is 1 Graphics: SDL_GL_CONTEXT_FLAGS is 0 Graphics: SDL_GL_CONTEXT_PROFILE_MASK is 2 Graphics: SDL_GL_SHARE_WITH_CURRENT_CONTEXT is 0 Graphics: SDL_GL_FRAMEBUFFER_SRGB_CAPABLE is 0 Graphics: OpenGL: Double buffering enabled Graphics: OpenGL: Max texture size: 2048 Graphics: OpenGL: ShadingLanguage: "1.10 - Intel Build 8.14.10.1930" * GRAPHICS REPORT VIDEO DRIVER windows pixel fmt 370546692 size 800 600 * END GRAPHICS REPORT

Here is it as a screenshot : http://prntscr.com/kf7k1p

Edited: 2018-08-06, 11:18
Top Quote
GunChleoc
Avatar
Joined: 2013-10-07, 15:56
Posts: 2891
Ranking
One Elder of Players
Location: RenderedRect
Posted at: 2018-08-06, 11:30

The shading language for your graphics driver is too old, so you have the following options:

  1. Try updating the graphics driver - if you're lucky, your graphics card will be able to handle it then
  2. If you laptop has 2 graphics cards, switch to the other graphics card (for example, my laptop has an Intel for power saving, plus an nVidia for higer-end applications)
  3. Downgrade to Build 18 face-sad.png

Busy indexing nil values

Top Quote
Lennart_XI
Avatar
Joined: 2018-08-06, 10:17
Posts: 3
Ranking
Just found this site
Posted at: 2018-08-06, 12:49

it seems like downgrading is the only solution but thx for youre fast support Ill try it back home with a GTX 1080

Edited: 2018-08-06, 12:53
Top Quote
GunChleoc
Avatar
Joined: 2013-10-07, 15:56
Posts: 2891
Ranking
One Elder of Players
Location: RenderedRect
Posted at: 2018-08-07, 14:59

Good luck!


Busy indexing nil values

Top Quote